MS does it again

MS has an optional quality update available in the last couple of days, so yesterday I decided to install the bugger. The update worked fine on all three of my Win 10 machines.

Or so I thought. Today I tried to start MS Edge on my main development PC, and nothing happened. Well, CRAP!

I checked Edge on the other two machines and the update didn't kill Edge.

I routinely make boot partition backups daily, so I can easily recover from problems like this. A Full backup done once a week on Thursday and the other days are differential backups based on the current full. As well as having a full backup done the beginning of a new month. I keep two weekly and and two monthly sets of backups.

Since I had a differential backup from a few hours before I did the optional update yesterday I ran a restore from that set and crossed my fingers Edge would start working again.

Yes!

M'ok, my default browser is an older version of FireFox, but some sites just don't work with any browser other than Edge. Not even IE.

Luckily I didn't lose anything I was working on that was important. :)
As it turns out the problem is even more MS "evil" than I previously thought. The new Edge v105, released today, has registry based Metrics Reporting Enabled issues on some machines. My main development machine is one of them.

The fix I found online doing a 'net search, and that works, is:

https://winaero.com/if-microsoft-edge-105-is-not-starting-try-this-fix/

Yeah, MS does it again, "this is another fine mess you got us into."
Last edited on
The fix I found online doing a 'net search, and that works, is:
https://winaero.com/if-microsoft-edge-105-is-not-starting-try-this-fix/

Thanks! Since yesterday, Edge was no longer starting on my machine, all of a sudden. No error message. No nothing 😨

Tried everything from "repairing" Edge, to re-installing Edge, to deleting all Edge-related data from %APPDATA%. Didn't help at all ☚ī¸

Now, removing this dubious MetricsReportingEnabled registry entry finally fixed it! 😊
Last edited on
Heh, someone reported me for providing information how-to fix "won't run" errors with the new version of Edge.

FYI, I had to log out of the new CPlusPlus version and log into the legacy version to post this.
I didn't realize other people had this issue. It hit me suddenly and I fixed it by installing the 104 version of Edge. Then I changed the permissions of the folder so Edge could try to update but fail.

That fix is better though, I'll try it soon.
The fix is IMO a rather simple yet elegant solution to a somewhat pervasive problem with the latest version of Edge.

As I said, with 3 Win 10 computers only one had Edge doing the dead cockroach.
kigar, I tried everything you did, all the supposed solutions of fixing Edge problems that should have worked. I even restored a backup from before Edge was updated from 104 to 105. Edge 104 worked. As soon as I started 104 and closed out the browser window Edge did a "silent update" to 105 and *SPLAT!*

I spent some frustrating minutes doing a 'net search until I found that website I posted earlier. As soon as I saw it was a rogue registry entry that needed to be deleted, HUZZAH!

After the fact I checked the registry on my two other Win 10 machines that didn't have Edge 105 problems and noticed that MetricsReportingEnabled key wasn't there.
Last edited on
Registered users can post here. Sign in or register to post.