Hi xanthian23,
If you look at the code I posted, it uses strings exclusively, and there is no strcmp or strcpy. I thought that was the whole idea of the assignment. I did have to change quite a few things to achieve that - but I used find & replace to do it. Same for the renaming of member variables.
The STL string is a really good thing, there is so much functionality in them - so much better than char arrays. You have now seen the assignment and equality testing, but lots of other things too like concatenation with the + and += operators. All kinds of good things here:
The main thing about your code is the interface (I don't mean the menu) - the way that class member variables are accessed & set. You have a bunch of functions that return a bool status, but the actual work is done the switch in main(). One of the benefits of good design is re-usability - you don't have this because to do so you would have the same code as what is in the switch in main, written again somewhere else. As my comments indicated, It would be better to put the code into the class - that way anything to do with the address book is in the addressbook class.
Another thought I had was to make PERSON a class of it's own, in it's own header file with an interface. I know a struct is almost the same thing as a class, but you have it a global lumped in with addressBook. Renaming it to CPerson or CAddrBkEntry would cause a bit of work with Find / Replace. My IDE allows me to do this globally.
I also have some more naming conventions - some of them are just my preference, others don't like them because it reminds them of Hungarian notation - which is bad when taken too far.
I put a leading C on my class names & use CamelCase for all variables, so I would have this:
class CAddressBook;
Sometimes this makes it easier to name objects.
Consistency in naming is a good thing - AddressBook & m_FName rather than addressBook & fName.
I also have a leading p for pointer variables, as in: pMyAddrBk . It is important to know that a variable is a pointer.
CAddressBook *pMyAddrBk = new CAddressBook();
There you go some more things to think about.