Your code is difficult to read with no code tags, all the extra blank lines, and no indentation.
What problem are you having with the code? Please be specific.
sellTicket(guardianPresent,movieRating,age);
You pass age, but age is an uninitialized variable. You do prompt for age within sellTicket, but it's a poor practice to pass uninitialized variables. age should be a local variable inside sellTicket and not passed as a parameter.
What do num1, num2 and num3 and outputMin() have to do with this problem? num1, num2, num3 are also uninitialized variables.
PLEASE USE CODE TAGS (the <> formatting button) when posting code.
It makes it easier to read your code and also easier to respond to your post. http://www.cplusplus.com/articles/jEywvCM9/
Hint: You can edit your post, highlight your code and press the <> formatting button.
You have been asked to use code tags. PLEASE DO SO. http://www.cplusplus.com/articles/jEywvCM9/
Hint: You can edit your post, highlight your code and press the <> formatting button.
If you're not going to make the slightest bit of effort to make your posts readable, why should we spend the slightest bit of effort helping you?
I will not respond further until you apply code tags.
I have to agree with the previous comment. Too many variables are not initialised, so the outputMin() function will make no sense at all. Validation would be needed around any inputs to check that the values being entered are not outside the allowable ranges.
Also, personally, I wouldn't use multiple returns from a switch statement. Just use breaks at the end of each select/case condition.
However, it's not clear in what way the function is not working. And it's not clear what purpose the outputMin() function is serving here.