what do you mean cleaning up? |
Just because it's working doesn't mean it's a good program.
ResidentBiscuit gave you a list of things that can be cleaned up.
More specifically:
1) getpackge() and Validpackge() are identical except for the case of the variable. Why have two nearly identical functions?
wildblue already suggested that you look at toupper() or tolower() to avoid having to deal with different cases.
2) Same issue with getHR except the duplicated logic is all in a single function.
3) Lines 10-12 are global variables. Using global variables is a poor practice.
4) Lines 26-29 flow issues. You do invalidcheck() last. Normal flow is to prompt for a particular input, accept the input, then check that the input is valid. If the input is not valid, display an error message and prompt for and accept input again.
5) You have identical couts for monthly_charges all over the place. There is no reason you need more than one (as long as it is in the right place).