Good Linux IDE?

Pages: 12
Hello, all. As you might (not) have guessed, I'm new to all these forums. I'm a Linux n00b looking for a good development IDE for it. I've done a lot of my Windows programming using Microsoft Visual C++, and I really just don't think I can get the hang of doing all the makefile and dependencies stuff manually. I know there's a "make" utility, but I've absolutely no clue on how to use it. I want to know this because I want to get my first Irrlicht project (not really that much, just a model and a particle fountain, with a few GUI elements) to compile and run under a Linux virtual machine I'm wanting to use as a sort of tester for it. I don't care about runtime speed, I'm just looking for an easy, as-pain-free-as-possible way to get it to run under Linux at all.
Last edited on
One of best them is Eclips
+1 Eclipse. It's also a good IDE for Windows/OS X
Last edited on
There's also KDevelop which I believe comes with most (possibly all) linux flavours
Code::Blocks = one of the best.
Eclipse, Code::Blocks (, KDevelop, these are the ones I think you might want to take a look at., all of them have nice features, Eclipse and KDevelop are very good for not only C++ but many different languages (the former is easy to expand with plugins) while Code::Blocks is designed for C++ but in my opinion it's code editor is superior to Eclipse's and KDevelop's own.
+1 NetBeans too
Thanks for all the replies! I've decided I'll use Code::Blocks for the Linux VM (it was the only one I could really get to work well). But I'm having a couple problems with it. One, I can't seem to compile any kind of app, even a console application (something about g++: not found or something like that), and two, if I start a new Irrlicht project (I was amazed it even had a pre-made project template for this!) and I give it my Irrlicht directory, it still complains of a missing irrlicht.h even though I know it's there. I've even copied it to the base directory, and it still can't find it.

What exactly am I doing wrong? It seemed simple enough, but I guess there's more to setting it up than just that.
Well, first thing to find out if there is a C++ compiler (the default setting is the GNU C++ compiler, g++) installed. Try this:
which g++
If it gives no output - and I think it will - then you will have to install it before doing anything. You will have to look that up for yourself, since it's distribution dependent, on Debian (and most likely other Debian based distros, like Ubuntu), it's
sudo apt-get install g++
As for Irrlicht, do you get this error message when you set up the project in the wizard?
Last edited on
Ok, well, I have the g++ compiler installed, and now I can compile console programs (yay!). But I'm still having problems setting up an Irrlicht project. I am using the wizard. Is there some bug with it or something?
Try the Irrlicht forums.
I think Netbeans maybe perfect for you.
it is easy to use.
I like its autocomplete function.
Netbeans is like VC++ IDE.
Last edited on
Use Codeblocks and tutorials @

Codeblocks kicks a$$

make sure you have build-essential (for ubuntu , dunno for other distros) ;)
i donwloaded Code::Blocks but i m total newbies n hence dunno hw 2 install it... :(
The program is a compressed archive of packages appropriate to your distribution. You have to decompress it

% tar xzf codeblocks_8.02-0ubuntu1.deb.tar.gz

Then install it using your package manager.

What are you using? (Ubuntu/Kubuntu? Debian? Fedora? SuSE? None of the above?)
Is there an IDE that can generate classes for creating GUI (such as using gtkmm) like Delphi?
I have been using kate. good for me so far and it works..just wish it could build and compile and execute.

I tried kdevelop and codeblock. nightmare for new user.

installed codeblock on kde 4.2 kubuntu 8.10 with g++ installed.
launched code block when good. used open file in code block and new project and wizard
and loaded my *.cpp file and clicked build button. and this is what i got

nothing to be done. <---output from the build log. loadeds in a .cpp file just dont seem to know its there.
cannot figure out how make this IDE functional. kdevelop atleast trys to compile but always ends up with error or cannot find target to exec.

where as kate and terminal. Always works but time consuming.

sure codeblock is great and kdevelop. but it is by no means very new user friendly. only took me 4 days to write text games and graphics with c++. and after week of frustration trying get IDE TO WORK. still no go.

if anyone knows how make codeblock functional. I would appriciate the advice.

Best Regards

@fik4n: wxDev-C++, GLADE etc.
@sigra: try the Code::block forum.
I done have. I was posting my experience on this forum due to fact someone ask what is a good IDE to use. hench my input.
sigra: I'd say you didn't add the file to the project, you just opened the file. Code::Blocks understood your command as "build this project which has nothing in it", rather than "build this file I have here".
Also, I take it all your programs so far have had just one file. Calling the compiler directly is simply impossible for big projects. "Big" meaning "at least 5 sources", although just 2 gets annoying.

I used to like Code::Blocks for Linux, until I found that Eclipse's code completion didn't suck balls and that I could set my own keyboard shortcuts. By the way, I find it very annoying that wxWidgets understands F10 like Windows understands left alt.
I'm still trying to find an IDE where looking at the contents of wide character C strings during debug is less painful than rubbing my eyes with diamond dust.
Pages: 12