Here's one place you could get some sound advice on style.
https://google.github.io/styleguide/cppguide.html
A couple of observations that might help you also:
1. Take advantage of whitespace, even within a line.
a = b
is easier to read than
a=b
2. single character variable names are bad - they lead to errors, are not easy to track and render the code almost unreadable except to the programmer. Good names lead to self-documenting code.
3. Capitalised names like Autovectores are better as autovectores - saves time and caps changes and generally only apply to class names
4. trigonometrical transfom equations are obscured by the same problem with variable names CO, SI would be better as cos, sin
e.g.
1 2 3
|
if (C<0){ T=-C-sqrtl(1.+C*C);}
else{ T=-C+sqrtl(1.+C*C); }
CO=1./sqrtl(1.+T*T);
|
reads much better, and is easier to check as:
1 2 3 4 5 6
|
if ( cos < 0 )
tan = -cos- sqrtl( 1. + cos * cos);
else
tan = -cos + sqrtl( 1. + cos * cos);
cos = 1. / sqrtl( 1. + tan * tan);
|
I'm guessing that T = tan etc, but you get the idea about whitespace and variable names I hope.
Cramming up everything and having multiple lines on a single line is considered by some programmers to be sophisticated and stylish. The reality is it is bad programming because it makes the code difficult to understand, test, debug and maintain. :)