I don't mean to be harsh or anything...but...that's just...
1) don't use using namespace std unless it's a very big project and you're actually using majority of the stuff in it...
2) don't use goto instead use a do/while loop
1 2 3 4
|
do
{
//stuff
} while( yesno == 'y' || yesno == 'Y' );
|
2b) Also yesno is kind of a bad name for a variable maybe something like
answer , response , continue_char , proceed_char or I supposed y_or_n_option or something along those lines. yesno is kind of vague and anyways that would imply it is a string not a character input.
3 ) L9 would look better as
if( number > 1 && number < 11 )
4) L10 you have the loop running 11 times instead of 10 and he wants to multiply by 1 , 2 , 3 ... 10 so it should be either
for( counter = 1 ; counter < 11; ++counter )
or
for( counter = 10; counter > 0 ; --counter )
or
for( counter = 0; counter < 10; ++counter )/*Then when you multiply multiply by counter + 1.*/
Those are the best options
IMO
5) lastly but the
most important proper indentation. I tried to tell you about this the other day =/
1 2 3 4 5 6 7 8 9 10 11 12
|
int main()
{
//4 spaces
loop()
{
//4 spaces
if()
{
//4 spaces
}
}
}
|
*4 spaces equals a tab. Most c++ text editors willl automatically indent but a lot of newer programmers like to remove them I have no idea why..it looks completely sloppy and you can not tell where your braces end.