So, I got my program to work, finally. But I just noticed I did it wrong (kind of). Every time the user enters -1 to display the summary the number of addition problems played is off if the user got an addition problem wrong and the question had to be repeated.
Essentially you want someone to debug your code. A major part of writing code is learning how to debug it yourself or even better writing code in a way that minimizes the chances of having too many bugs in the first place. If you know how your code works you can often work out where the error is from the results. For example the error total is being incremented somewhere along with the correct total.
By the way I would use meaningful names for your variables. This is a form of self commenting the code. Thus aaa and bbb should be something like num1 and num2. You ccc and ddd variables can be removed as you don't actually use them.
I will look over your code and reply later unless someone jumps in earlier with a solution.
I know why it is displaying the # of additions wrong, because played++ is in the do while loop, and the else statement runs the do loop every time the answer is wrong, but I don't know how to change the code to keep the program running and display played++ correctly.
I read the opposite, that you want variables that won't show up often in code like you are less likely to see, 'aaa' than 'num'?
ccc and ddd are from a previous attempt that did not work, I will delete it.
The compiler should flag unused variables.
The incorrect number is play - correct cout << "Number of times answered incorrectly: " << play-correct << endl;
Also the total games played seems to be adding the -1 action as another play?
Also some code is common to the four options and this often means you can simplify it.
By the way I would use meaningful names for your variables.
Yea, the compilers today take long names. There's no excuse to have obscure variable names. It is bad form and should be eliminated from the beginning. The best code is clear code, not convoluted or obscure code. Add the else even when drop through is fine if it makes the code clearer.