Ok, this is genuine.
I don't like to do lengthy typing, so I tend to go with shot monikers for variable names: boundingbox is bb, vector is v, etc, etc, etc;
Well, my current project is a two parter. The first part scans a 3D geometry and computes the volume. It does this by placing a spanner at an x,y coordinate in 3D space and then does parametric hits against a plane, then tests to see if that hit occurs within the triangle that defines the boundaries of the geometry. I call this a span hit. The spanner is defined by four points that make up a 2D geometry of a current resolution of 0.001 (essentially, this is a millimeter by context). This part links in with the paragraph above when you see the quoted post and I hope it doesn't offend anyone.
The second part is still waiting for me to work on it, but that is neither her nor there.
Anyway, I opened up my project to begin working on an idea and I noticed this in my code:
1 2 3 4 5
|
// test for hit on the plane
for( int i = 0; i < 4; i++ )
{
sh[i].t =
}
|
and I started to wonder why is there obscenities in my code. I'm going to have to rethink my naming system.
Have any of you similar stories to share about how your coding style made you wonder what you're thinking?